lkml.org 
[lkml]   [2022]   [Jul]   [9]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 03/10] dt-bindings: PCI: qcom: Enumerate platforms with single msi interrupt
On Wed, Jun 29, 2022 at 04:09:53PM +0200, Johan Hovold wrote:
> Explicitly enumerate the older platforms that have a single msi host
> interrupt. This allows for adding further platforms without resorting
> to nested conditionals.
>
> Drop the redundant comment about older chipsets instead of moving it.
>
> Signed-off-by: Johan Hovold <johan+linaro@kernel.org>

With the comment from Krzysztof on wording mentioned in patch 4/10
addressed,

Reviewed-by: Manivannan Sadhasivam <manivannan.sadhasivam@linaro.org>

Thanks,
Mani


> ---
> .../devicetree/bindings/pci/qcom,pcie.yaml | 17 +++++++++++++++--
> 1 file changed, 15 insertions(+), 2 deletions(-)
>
> diff --git a/Documentation/devicetree/bindings/pci/qcom,pcie.yaml b/Documentation/devicetree/bindings/pci/qcom,pcie.yaml
> index a1b4fc70e162..8560c65e6f0b 100644
> --- a/Documentation/devicetree/bindings/pci/qcom,pcie.yaml
> +++ b/Documentation/devicetree/bindings/pci/qcom,pcie.yaml
> @@ -625,7 +625,6 @@ allOf:
> - reset-names
>
> # On newer chipsets support either 1 or 8 msi interrupts
> - # On older chipsets it's always 1 msi interrupt
> - if:
> properties:
> compatible:
> @@ -660,7 +659,21 @@ allOf:
> - const: msi5
> - const: msi6
> - const: msi7
> - else:
> +
> + - if:
> + properties:
> + compatible:
> + contains:
> + enum:
> + - qcom,pcie-apq8064
> + - qcom,pcie-apq8084
> + - qcom,pcie-ipq4019
> + - qcom,pcie-ipq6018
> + - qcom,pcie-ipq8064
> + - qcom,pcie-ipq8064-v2
> + - qcom,pcie-ipq8074
> + - qcom,pcie-qcs404
> + then:
> properties:
> interrupts:
> maxItems: 1
> --
> 2.35.1
>

--
மணிவண்ணன் சதாசிவம்

\
 
 \ /
  Last update: 2022-07-09 09:59    [W:0.209 / U:0.928 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site