lkml.org 
[lkml]   [2022]   [Jul]   [14]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH v8 01/14] ALSA: hda: hda_cs_dsp_ctl: Add Library to support CS_DSP ALSA controls
On Thu, 14 Jul 2022 11:03:16 +0200,
Takashi Iwai wrote:
>
> On Thu, 30 Jun 2022 02:23:22 +0200,
> Vitaly Rodionov wrote:
> > --- a/sound/pci/hda/Kconfig
> > +++ b/sound/pci/hda/Kconfig
> > @@ -94,6 +94,10 @@ config SND_HDA_PATCH_LOADER
> > config SND_HDA_SCODEC_CS35L41
> > tristate
> >
> > +config SND_HDA_CS_DSP_CONTROLS
> > + tristate
> > + depends on CS_DSP
> > +
> > config SND_HDA_SCODEC_CS35L41_I2C
> > tristate "Build CS35L41 HD-audio side codec support for I2C Bus"
> > depends on I2C
>
> This change alone doesn't give anything useful, unfortunately.
>
> The above form (without prompt) is basically only to be "selected" by
> others. And when selected, the "depends" there is just ignored, so
> it's useless.
>
> That is, a proper way would be something like:
>
> config SND_HDA_CS_DSP_CONTROLS
> tristate
>
> config SND_HDA_SCODEC_CS35L41
> ....
> select SND_HDA_CS_DSP_CONTROLS if CS_DSP
>
> ... if you want / need to enable CONFIG_SND_HDA_CS_DSP_CONTROLS
> conditionally.

And now I see that the patch 4 has those selects (but select both
SND_HDA_CS_DSP_CONTROLS and CS_DSP). So what we need here is to drop
the superfluous "depends on CS_DSP" and mention in the description
that the Kconfig will be actually enabled in the later patch.


thanks,

Takashi

\
 
 \ /
  Last update: 2022-07-14 11:07    [W:0.065 / U:0.600 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site