lkml.org 
[lkml]   [2022]   [Jun]   [29]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Date
SubjectRe: [PATCH 2/4] serial: 8250_dw: Rename offset to reg_offset
On Wed, Jun 29, 2022 at 9:52 AM Ilpo Järvinen
<ilpo.jarvinen@linux.intel.com> wrote:
>
> On Wed, 29 Jun 2022, Andy Shevchenko wrote:
>
> > On Tue, Jun 28, 2022 at 04:42:32PM +0300, Ilpo Järvinen wrote:
> > > Get 'offset' variable out of the way of parameter named 'offset',
> > > rename it to 'reg_offset'. This is very short lived change as

a very

> > > reg_offset is going to be soon removed.
> >
> > I'm not sure why this change then even needed...
>
> I could either:
> 1) create one large patch doing many thing (2+3 or 2+3+4)
> or
> 2) add the 'offset' parameter with some other name first and rename it
> to its final name after local var 'offset' is eliminated by patch 4
> or
> 3) rename local var 'offset' first out of the way so that I can add
> 'offset' parameter in patch 3 (=this patch)
>
> If I just drop patch 2 and only do 3, it won't build because 'offset'
> variable appears twice (as arg and local var).

Now I got it, thanks. See one remark above.

--
With Best Regards,
Andy Shevchenko

\
 
 \ /
  Last update: 2022-06-29 11:40    [W:0.040 / U:0.104 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site