Messages in this thread |  | | Date | Mon, 18 Apr 2022 11:23:27 +0800 | From | Tzung-Bi Shih <> | Subject | Re: [PATCH 1/3] platform/chrome: cros_ec_proto: Add peripheral charger count API |
| |
On Thu, Apr 14, 2022 at 05:32:51PM -0700, Stephen Boyd wrote: > Add a peripheral charger count API similar to the one implemented in the > ChromeOS PCHG driver so we can use it to decide whether or not to > register the PCHG device in the cros_ec MFD driver. > > Cc: Lee Jones <lee.jones@linaro.org> > Cc: Daisuke Nojiri <dnojiri@chromium.org> > Cc: Benson Leung <bleung@chromium.org> > Cc: Guenter Roeck <groeck@chromium.org> > Cc: <chrome-platform@lists.linux.dev> > Signed-off-by: Stephen Boyd <swboyd@chromium.org>
With a minor comment about the naming, Reviewed-by: Tzung-Bi Shih <tzungbi@kernel.org>
> diff --git a/include/linux/platform_data/cros_ec_proto.h b/include/linux/platform_data/cros_ec_proto.h > index df3c78c92ca2..8f5781bc2d7a 100644 > --- a/include/linux/platform_data/cros_ec_proto.h > +++ b/include/linux/platform_data/cros_ec_proto.h > @@ -230,6 +230,7 @@ u32 cros_ec_get_host_event(struct cros_ec_device *ec_dev); > bool cros_ec_check_features(struct cros_ec_dev *ec, int feature); > > int cros_ec_get_sensor_count(struct cros_ec_dev *ec); > +unsigned int cros_ec_pchg_port_count(struct cros_ec_dev *ec);
I wonder if "cros_ec_get_pchg_port_count" would be a better name for the API.
|  |