lkml.org 
[lkml]   [2022]   [Mar]   [7]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    Patch in this message
    /
    From
    Subject[PATCH 5.15 168/262] net: ipa: add an interconnect dependency
    Date
    From: Alex Elder <elder@linaro.org>

    commit 1dba41c9d2e2dc94b543394974f63d55aa195bfe upstream.

    In order to function, the IPA driver very clearly requires the
    interconnect framework to be enabled in the kernel configuration.
    State that dependency in the Kconfig file.

    This became a problem when CONFIG_COMPILE_TEST support was added.
    Non-Qualcomm platforms won't necessarily enable CONFIG_INTERCONNECT.

    Reported-by: kernel test robot <lkp@intel.com>
    Fixes: 38a4066f593c5 ("net: ipa: support COMPILE_TEST")
    Signed-off-by: Alex Elder <elder@linaro.org>
    Link: https://lore.kernel.org/r/20220301113440.257916-1-elder@linaro.org
    Signed-off-by: Jakub Kicinski <kuba@kernel.org>
    Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
    ---
    drivers/net/ipa/Kconfig | 1 +
    1 file changed, 1 insertion(+)

    --- a/drivers/net/ipa/Kconfig
    +++ b/drivers/net/ipa/Kconfig
    @@ -2,6 +2,7 @@ config QCOM_IPA
    tristate "Qualcomm IPA support"
    depends on NET && QCOM_SMEM
    depends on ARCH_QCOM || COMPILE_TEST
    + depends on INTERCONNECT
    depends on QCOM_RPROC_COMMON || (QCOM_RPROC_COMMON=n && COMPILE_TEST)
    select QCOM_MDT_LOADER if ARCH_QCOM
    select QCOM_SCM

    \
     
     \ /
      Last update: 2022-03-07 11:15    [W:2.067 / U:0.500 seconds]
    ©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site