lkml.org 
[lkml]   [2022]   [Mar]   [7]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
Subject[GIT PULL] mtd: Fixes for the next -rc/v5.17 final
Hello Linus,

The following changes since commit ffb217a13a2eaf6d5bd974fc83036a53ca69f1e2:

Linux 5.17-rc7 (2022-03-06 14:28:31 -0800)

are available in the Git repository at:

git://git.kernel.org/pub/scm/linux/kernel/git/mtd/linux.git tags/mtd/fixes-for-5.17-rc8

for you to fetch changes up to 42da5a4ba17070e9d99abf375a5bd70e85d2a6b8:

mtd: rawnand: omap2: Actually prevent invalid configuration and build error (2022-03-07 17:46:54 +0100)

----------------------------------------------------------------
As part of a previous changeset introducing support for the K3
architecture, the OMAP_GPMC (a non visible symbol) got selected by the
selection of MTD_NAND_OMAP2 instead of doing so from the architecture
directly (like for the other users of these two drivers). Indeed, from a
hardware perspective, the OMAP NAND controller needs the GPMC to
work.

This led to a robot error which got addressed in fix merge into
-rc4. Unfortunately, the approach at this time still used "select" and
lead to further robot reports.

This time we switch to "depends on" in order to prevent random
misconfigurations. The different dependencies will however need a future
cleanup.

----------------------------------------------------------------
Roger Quadros (1):
mtd: rawnand: omap2: Actually prevent invalid configuration and build error

drivers/mtd/nand/raw/Kconfig | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)

\
 
 \ /
  Last update: 2022-03-07 18:20    [W:0.058 / U:0.556 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site