lkml.org 
[lkml]   [2022]   [Mar]   [21]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: [PATCH v3 14/18] dt-bindings: clock: Convert qcom,krait-cc to yaml
Date
On Sun, 20 Mar 2022 12:34:26 +0100, Ansuel Smith wrote:
> Convert qcom,krait-cc to yaml Documentation.
>
> Signed-off-by: Ansuel Smith <ansuelsmth@gmail.com>
> ---
> .../bindings/clock/qcom,krait-cc.txt | 34 -----------
> .../bindings/clock/qcom,krait-cc.yaml | 59 +++++++++++++++++++
> 2 files changed, 59 insertions(+), 34 deletions(-)
> delete mode 100644 Documentation/devicetree/bindings/clock/qcom,krait-cc.txt
> create mode 100644 Documentation/devicetree/bindings/clock/qcom,krait-cc.yaml
>

My bot found errors running 'make DT_CHECKER_FLAGS=-m dt_binding_check'
on your patch (DT_CHECKER_FLAGS is new in v5.13):

yamllint warnings/errors:

dtschema/dtc warnings/errors:
/builds/robherring/linux-dt-review/Documentation/devicetree/bindings/clock/qcom,krait-cc.example.dt.yaml: clock-controller: clocks: [[4294967295], [4294967295], [4294967295], [4294967295], [4294967295], [4294967295], [4294967295]] is too long
From schema: /builds/robherring/linux-dt-review/Documentation/devicetree/bindings/clock/qcom,krait-cc.yaml

doc reference errors (make refcheckdocs):

See https://patchwork.ozlabs.org/patch/1607456

This check can fail if there are any dependencies. The base for a patch
series is generally the most recent rc1.

If you already ran 'make dt_binding_check' and didn't see the above
error(s), then make sure 'yamllint' is installed and dt-schema is up to
date:

pip3 install dtschema --upgrade

Please check and re-submit.

\
 
 \ /
  Last update: 2022-03-21 14:36    [W:0.089 / U:0.056 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site