Messages in this thread Patch in this message |  | | From | Miaohe Lin <> | Subject | [PATCH] mm/mremap:: Use vma_lookup() instead of find_vma() | Date | Sat, 12 Mar 2022 16:31:18 +0800 |
| |
Using vma_lookup() verifies the address is contained in the found vma. This results in easier to read the code.
Signed-off-by: Miaohe Lin <linmiaohe@huawei.com> --- mm/mremap.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/mm/mremap.c b/mm/mremap.c index 002eec83e91e..9d76da79594d 100644 --- a/mm/mremap.c +++ b/mm/mremap.c @@ -942,8 +942,8 @@ SYSCALL_DEFINE5(mremap, unsigned long, addr, unsigned long, old_len, if (mmap_write_lock_killable(current->mm)) return -EINTR; - vma = find_vma(mm, addr); - if (!vma || vma->vm_start > addr) { + vma = vma_lookup(mm, addr); + if (!vma) { ret = EFAULT; goto out; } -- 2.23.0
|  |