lkml.org 
[lkml]   [2022]   [Jan]   [5]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 2/8] dt-bindings: nvmem: add transformation bindings
Am 2022-01-04 16:03, schrieb Rob Herring:
> On Tue, Dec 28, 2021 at 03:25:43PM +0100, Michael Walle wrote:
>> Just add a simple list of the supported devices which need a nvmem
>> transformations.
>>
>> Also, since the compatible string is prepended to the actual nvmem
>> compatible string, we need to match using "contains" instead of an
>> exact
>> match.
>>
>> Signed-off-by: Michael Walle <michael@walle.cc>
>> ---
>> .../devicetree/bindings/mtd/mtd.yaml | 7 +--
>> .../bindings/nvmem/nvmem-transformations.yaml | 46
>> +++++++++++++++++++
>> 2 files changed, 50 insertions(+), 3 deletions(-)
>> create mode 100644
>> Documentation/devicetree/bindings/nvmem/nvmem-transformations.yaml
>>
>> diff --git a/Documentation/devicetree/bindings/mtd/mtd.yaml
>> b/Documentation/devicetree/bindings/mtd/mtd.yaml
>> index 376b679cfc70..0291e439b6a6 100644
>> --- a/Documentation/devicetree/bindings/mtd/mtd.yaml
>> +++ b/Documentation/devicetree/bindings/mtd/mtd.yaml
>> @@ -33,9 +33,10 @@ patternProperties:
>>
>> properties:
>> compatible:
>> - enum:
>> - - user-otp
>> - - factory-otp
>> + contains:
>> + enum:
>> + - user-otp
>> + - factory-otp
>
> If the addition is only compatible strings, then I would just add them
> here. Otherwise this needs to be structured a bit differently. More on
> that below.

I wanted to avoid having these compatible strings "cluttered" all around
the various files. Esp. having a specific compatible string in a generic
mtd.yaml. But if everyone is fine with that, I'll just move it here.

>>
>> required:
>> - compatible
>> diff --git
>> a/Documentation/devicetree/bindings/nvmem/nvmem-transformations.yaml
>> b/Documentation/devicetree/bindings/nvmem/nvmem-transformations.yaml
>> new file mode 100644
>> index 000000000000..8c8d85fd6d27
>> --- /dev/null
>> +++
>> b/Documentation/devicetree/bindings/nvmem/nvmem-transformations.yaml
>> @@ -0,0 +1,46 @@
>> +# SPDX-License-Identifier: (GPL-2.0 OR BSD-2-Clause)
>> +%YAML 1.2
>> +---
>> +$id: http://devicetree.org/schemas/nvmem/nvmem-transformations.yaml#
>> +$schema: http://devicetree.org/meta-schemas/core.yaml#
>> +
>> +title: NVMEM transformations Device Tree Bindings
>> +
>> +maintainers:
>> + - Srinivas Kandagatla <srinivas.kandagatla@linaro.org>
>> +
>> +description: |
>> + This is a list NVMEM devices which need transformations.
>> +
>> +properties:
>> + compatible:
>> + oneOf:
>> + - items:
>> + - enum:
>> + - kontron,sl28-vpd
>> + - const: user-otp
>> + - const: user-otp
>
> This will be applied to any node containing 'user-otp'. You need a
> custom 'select' to avoid that.

Out of curiosity, you mean something like:

select:
compatible:
contains:
enum:
- kontron,sl28-vpd

\
 
 \ /
  Last update: 2022-01-05 09:26    [W:0.123 / U:1.312 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site