[lkml]   [2021]   [Jul]   [28]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH v2 5/7] kallsyms: Rename is_kernel() and is_kernel_text()

On 2021/7/28 23:28, Steven Rostedt wrote:
> On Wed, 28 Jul 2021 16:13:18 +0800
> Kefeng Wang <> wrote:
>> The is_kernel[_text]() function check the address whether or not
>> in kernel[_text] ranges, also they will check the address whether
>> or not in gate area, so use better name.
> Do you know what a gate area is?
> Because I believe gate area is kernel text, so the rename just makes it
> redundant and more confusing.

Yes, the gate area(eg, vectors part on ARM32, similar on x86/ia64) is
kernel text.

I want to keep the 'basic' section boundaries check, which only check
the start/end

of sections, all in section.h,  could we use 'generic' or 'basic' or
'core' in the naming?

* is_kernel_generic_data() --- come from core_kernel_data() in kernel.h
* is_kernel_generic_text()

The old helper could remain unchanged, any suggestion, thanks.

> -- Steve
> .

 \ /
  Last update: 2021-07-29 04:01    [W:0.116 / U:0.256 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site