lkml.org 
[lkml]   [2021]   [Jul]   [26]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: [v2 1/8] dt-bindings: iio: adc: rename the aspeed adc yaml
Date
Hi Jonathan,

On 2021/7/23, 10:45 PM, "Jonathan Cameron" <Jonathan.Cameron@Huawei.com> wrote:

On Fri, 23 Jul 2021 16:16:14 +0800
Billy Tsai <billy_tsai@aspeedtech.com> wrote:

> > The aspeed,ast2400-adc.yaml not only descriptor the bindings of ast2400.
> > Rename it to aspeed,adc.yaml for all of the aspeed adc bindings.
> >
> > Signed-off-by: Billy Tsai <billy_tsai@aspeedtech.com>

> We try to avoid 'wild' card type namings most of the time and instead
> name after a particular part number. I say try because clearly
> we let a few in over the years :(

> It is very hard to know if this binding will apply to 'all' future
> aspeed ADCs.

> As such I'm not sure this particular rename makes sense.

If I want to extend the yaml file to compatible more versions of the aspeed adc.
Would you suggest to add new files call aspeed,ast2600-adc.yaml or just append it
to the aspeed,ast2400-adc.yaml?

Thanks

Best Regards,
Billy Tsai


\
 
 \ /
  Last update: 2021-07-26 08:54    [W:0.064 / U:3.656 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site