lkml.org 
[lkml]   [2021]   [Feb]   [27]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH v4 02/10] coresight: syscfg: Add registration and feature loading for cs devices
On Fri, Feb 26, 2021 at 07:14:32PM +0000, Mike Leach wrote:
> Hi Mathieu,
>
> On Fri, 19 Feb 2021 at 18:43, Mathieu Poirier
> <mathieu.poirier@linaro.org> wrote:
> >
> > [...]
> >
> > > +/**
> > > + * List entry for Coresight devices that are registered as supporting complex
> > > + * config operations.
> > > + *
> > > + * @csdev: The registered device.
> > > + * @match_info: The matching type information.
> > > + * @ops: Operations supported by the registered device.
> > > + * @item: list entry.
> > > + */
> > > +struct cscfg_csdev_register {
> > > + struct coresight_device *csdev;
> > > + struct cscfg_match_desc match_info;
> > > + struct cscfg_csdev_feat_ops ops;
> > > + struct list_head item;
> > > +};
> >
> > I would call this structure cscfg_registered_csdev and move it to
> > coresight-config.h. That way it is consistent with cscfg_config_csdev and
> > cscfg_feature_csdev and located all in the same file.
> >
>
> I was trying to separate structures that are used to define
> configurations and features, with those that are used to manage the
> same. Hence, most things in coresight_config.h define configurations,
> or their device loaded instance equivalents, and things in
> coresight_syscfg.h are management items. I am happy to change the name
> but would prefer is stay in coresight_syscfg.h

Ok

>
> Thanks
>
> Mike
>

\
 
 \ /
  Last update: 2021-02-27 21:54    [W:0.966 / U:0.224 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site