lkml.org 
[lkml]   [2021]   [Feb]   [21]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH] virtio: don't prompt CONFIG_VIRTIO_PCI_MODERN
From
Date

On 2021/2/19 11:38 下午, Guenter Roeck wrote:
> On 2/19/21 12:45 AM, Jason Wang wrote:
>> We used to prompt CONFIG_VIRTIO_PCI_MODERN to user which may bring a
>> lot of confusion. E.g it may break various default configs which want
>> virtio devices.
>>
>> So this patch fixes this by hide the prompot and document the
> ... by hiding the prompt and documenting ...


Hi Michael:

Would you like me to post a new version or you can fix those typos when
applying the patch?

Thanks


>
>> dependency.
>>
>> Cc: Arnd Bergmann <arnd@arndb.de>
>> Cc: Anders Roxell <anders.roxell@linaro.org>
>> Cc: Guenter Roeck <linux@roeck-us.net>
>> Reported-by: Naresh Kamboju <naresh.kamboju@linaro.org>
>> Fixes: 86b87c9d858b6 ("virtio-pci: introduce modern device module")
>> Signed-off-by: Jason Wang <jasowang@redhat.com>
> Reviewed-by: Guenter Roeck <linux@roeck-us.net>
>
>> ---
>> drivers/virtio/Kconfig | 9 +++++----
>> 1 file changed, 5 insertions(+), 4 deletions(-)
>>
>> diff --git a/drivers/virtio/Kconfig b/drivers/virtio/Kconfig
>> index 6b9b81f4b8c2..be7df369bc2b 100644
>> --- a/drivers/virtio/Kconfig
>> +++ b/drivers/virtio/Kconfig
>> @@ -13,12 +13,12 @@ config ARCH_HAS_RESTRICTED_VIRTIO_MEMORY_ACCESS
>> VIRTIO_F_ACCESS_PLATFORM
>>
>> config VIRTIO_PCI_MODERN
>> - tristate "Modern Virtio PCI Device"
>> - depends on PCI
>> + tristate
>> help
>> Modern PCI device implementation. This module implements the
>> basic probe and control for devices which are based on modern
>> - PCI device with possible vendor specific extensions.
>> + PCI device with possible vendor specific extensions. Any
>> + module that selects this module must depend on PCI.
>>
>> menuconfig VIRTIO_MENU
>> bool "Virtio drivers"
>> @@ -28,7 +28,8 @@ if VIRTIO_MENU
>>
>> config VIRTIO_PCI
>> tristate "PCI driver for virtio devices"
>> - depends on VIRTIO_PCI_MODERN
>> + depends on PCI
>> + select VIRTIO_PCI_MODERN
>> select VIRTIO
>> help
>> This driver provides support for virtio based paravirtual device
>>

\
 
 \ /
  Last update: 2021-02-22 04:45    [W:0.113 / U:42.160 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site