lkml.org 
[lkml]   [2021]   [Dec]   [6]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH] staging: vt6655: refactor byMinChannel to min_channel
On Sat, Dec 04, 2021 at 10:09:41AM +0100, Alberto Merciai wrote:
> On Sat, Dec 04, 2021 at 11:27:43AM +0300, Pavel Skripkin wrote:
> > Looks like this variable is set, but never used. Shouldn't it be just
> > removed?
> >
> > Same for max_channel (or byMaxChannel).
>
> To be honest, I would prefer leave them where they are. I'm only
> refactoring the code considering less the logic aspect.
>

Pavel is right.

You should always be looking for that kind of stuff instead of just
doing a sed script. And the thing is you're in the best place to think
about how each struct member is used right now because you're modifying
each use to make sure it compiles. There is a possibility that no one
else will think about it ever again now that checkpatch doesn't
complain.

So in a way, it's better to leave the checkpatch warning as-is until
someone can fix it properly.

> I don't know if these variables will become usefull in a second
> moment.

No. We do not write code for the future. No one knows what the future
will hold. Delete any code which is not currently useful.

regards,
dan carpenter

\
 
 \ /
  Last update: 2021-12-06 14:32    [W:0.076 / U:5.048 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site