lkml.org 
[lkml]   [2021]   [Dec]   [3]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH] xen-blkfront: Use the bitmap API when applicable
From
Date
On Fri, 2021-12-03 at 16:54 +0100, Christophe JAILLET wrote:
> Le 03/12/2021 à 04:03, Joe Perches a écrit :
> > On Thu, 2021-12-02 at 20:07 +0100, Christophe JAILLET wrote:
> > > Le 02/12/2021 à 19:16, Joe Perches a écrit :
> > > > On Thu, 2021-12-02 at 19:12 +0100, Christophe JAILLET wrote:
> > > > > Le 02/12/2021 à 07:12, Juergen Gross a écrit :
> > > > > > On 01.12.21 22:10, Christophe JAILLET wrote:
> > > > > > > Use 'bitmap_zalloc()' to simplify code, improve the semantic and avoid
> > > > > > > some open-coded arithmetic in allocator arguments.
> > > > > > >
> > > > > > > Also change the corresponding 'kfree()' into 'bitmap_free()' to keep
> > > > > > > consistency.
> > > > > > >
> > > > > > > Use 'bitmap_copy()' to avoid an explicit 'memcpy()'
> > > > []
> > > > > > > diff --git a/drivers/block/xen-blkfront.c b/drivers/block/xen-blkfront.c
> > > > []
> > > > > > > @@ -442,16 +442,14 @@ static int xlbd_reserve_minors(unsigned int
> > > > > > > minor, unsigned int nr)
> > > > > > >       if (end > nr_minors) {
> > > > > > >           unsigned long *bitmap, *old;
> > > > > > > -        bitmap = kcalloc(BITS_TO_LONGS(end), sizeof(*bitmap),
> > > > > > > -                 GFP_KERNEL);
> > > > > > > +        bitmap = bitmap_zalloc(end, GFP_KERNEL);
> > > > > > >           if (bitmap == NULL)
> > > > > > >               return -ENOMEM;
> > > > > > >           spin_lock(&minor_lock);
> > > > > > >           if (end > nr_minors) {
> > > > > > >               old = minors;
> > > > > > > -            memcpy(bitmap, minors,
> > > > > > > -                   BITS_TO_LONGS(nr_minors) * sizeof(*bitmap));
> > > > > > > +            bitmap_copy(bitmap, minors, nr_minors);
> > > > > > >               minors = bitmap;
> > > > > > >               nr_minors = BITS_TO_LONGS(end) * BITS_PER_LONG;
> > > >
> > > > nr_minors = end;
> > > > ?
> > > >
> > >
> > > No,
> > > My understanding of the code is that if we lack space (end > nr_minors),
> > > we need to allocate more. In such a case, we want to keep track of what
> > > we have allocated, not what we needed.
> > > The "padding" bits in the "long align" allocation, can be used later.
> >
> > >
> > > first call
> > > ----------
> > > end = 65
> > > nr_minors = 63
> > >
> > > --> we need some space
> > > --> we allocate 2 longs = 128 bits
> > > --> we now use 65 bits of these 128 bits
> >
> > or 96, 32 or 64 bit longs remember.
>
> 32 and 64 for sure, but I was not aware of 96. On which arch?

For more clarity that should have been a period instead of comma after 96.


> > The initial allocation is now bitmap_zalloc which
> > specifies only bits and the nr_minors is then in
> > BITS_TO_LONGS(bits) * BITS_PER_LONG
> >
> > Perhaps that assumes too much about the internal
> > implementation of bitmap_alloc
>
> I get your point now, and I agree with you.
>
> Maybe something as what is done in mc-entity.c?
> Explicitly require more bits (which will be allocated anyway), instead
> of taking advantage (read "hoping") that it will be done.

Sure, that's sensible.

> Could be:
>
> @@ -440,26 +440,25 @@ static int xlbd_reserve_minors(unsigned int minor,
> unsigned int nr)
> int rc;
>
> if (end > nr_minors) {
> unsigned long *bitmap, *old;
>
> - bitmap = kcalloc(BITS_TO_LONGS(end), sizeof(*bitmap),
> - GFP_KERNEL);
> + end = ALIGN(end, BITS_PER_LONG);

Though it may be more sensible to use some other alignment
like round_up and not use BITS_PER_LONG at all as the
number of these may not be dependent on 32/64 bit arches
at all.

Maybe something like:

#define GROW_MINORS 64

end = round_up(nr_minors, GROW_MINORS);

etc...

\
 
 \ /
  Last update: 2021-12-03 17:10    [W:0.068 / U:1.856 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site