lkml.org 
[lkml]   [2021]   [Dec]   [12]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH v2] MIPS: Makefile: Remove "ifdef need-compiler" for Kbuild.platforms
On Mon, Dec 13, 2021 at 09:35:20AM +0900, Ryutaroh Matsumoto wrote:
> From: Masahiro Yamada <masahiroy@kernel.org>
> Subject: Re: [PATCH v2] MIPS: Makefile: Remove "ifdef need-compiler" for Kbuild.platforms
> Date: Sat, 11 Dec 2021 01:39:10 +0900
> > Nathan's patch cleaned up arch/mips/loognson2ef/Platform,
> > but I still see similar code in arch/mips/sgi-ip22/Platform.
> >
> >
> > ifdef CONFIG_SGI_IP28
> > ifeq ($(call cc-option-yn,-march=r10000 -mr10k-cache-barrier=store), n)
> > $(error gcc doesn't support needed option -mr10k-cache-barrier=store)
> > endif
> > endif
> >
> >
> > Doesn't this cause a failure of *-pkg builds for sgi-ip22 platform?
>
> Yes, it does, as reported at
> https://github.com/ClangBuiltLinux/linux/issues/1543

It seems like that section can be removed for the same reason as my
patch (that flag is supported with GCC 5.1.0) then this patch can be
applied without any issues.

Cheers,
Nathan

\
 
 \ /
  Last update: 2021-12-13 03:10    [W:0.050 / U:1.740 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site