[lkml]   [2021]   [Oct]   [20]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [GIT PULL] NIOS2: fix for v5.15, part 2
On Mon, Oct 18, 2021 at 9:59 AM Dinh Nguyen <> wrote:
> - Renamed CTL_STATUS to CTL_FSTATUS to fix a redefined warning

Hmm. That's still some very generic names exposed in a arch header
file that seems to get included (indirectly) almost everywhere.

I've pulled this, but I would suggest you name those flags not "CTL"
but something that is more exclusive to nios2.

Btw, the same goes for some of the other macros in there that are
currently unique - like "RDCTL". That's a name that I can see a driver
using internally, and with nios2 being so unusual, it would take
potentially a longish time before anybody even noticed.


 \ /
  Last update: 2021-10-20 18:03    [W:0.048 / U:0.156 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site