lkml.org 
[lkml]   [2021]   [Oct]   [20]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [RFC PATCH v4] workqueue: Introduce show_one_worker_pool and show_one_workqueue.
On Wed, Oct 20, 2021 at 02:09:00PM +1100, Imran Khan wrote:
> Currently show_workqueue_state shows the state of all workqueues and of
> all worker pools. In certain cases we may need to dump state of only a
> specific workqueue or worker pool. For example in destroy_workqueue we
> only need to show state of the workqueue which is getting destroyed.
>
> So rename show_workqueue_state to show_all_workqueues(to signify it
> dumps state of all busy workqueues) and divide it into more granular
> functions (show_one_workqueue and show_one_worker_pool), that would show
> states of individual workqueues and worker pools and can be used in
> cases such as the one mentioned above.
>
> Also, as mentioned earlier, make destroy_workqueue dump data pertaining
> to only the workqueue that is being destroyed and make user(s) of
> earlier interface(show_workqueue_state), use new interface
> (show_all_workqueues).
>
> Signed-off-by: Imran Khan <imran.f.khan@oracle.com>
> ---
> Changes in v4:
> - Rebase on git://git.kernel.org/pub/scm/linux/kernel/git/tj/wq.git
> for-5.16

"RFC" means "I am not sure about this patch, please do not apply it."

Yet a v4 is very odd, why not be sure about this?

thanks,

greg k-h

\
 
 \ /
  Last update: 2021-10-20 08:01    [W:0.085 / U:0.368 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site