[lkml]   [2021]   [Jan]   [30]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH 1/2] docs: Make syscalls' helpers naming consistent
On Fri, Jan 29, 2021 at 10:45:46PM -0300, André Almeida wrote:
> The documentation explains the need to create internal syscalls' helpers,
> and that they should be called `kern_xyzzy()`. However, the comment at
> include/linux/syscall.h says that they should be named as
> `ksys_xyzzy()`, and so are all the helpers declared bellow it. Change the
> documentation to reflect this.
> Cc: Dominik Brodowski <>
> Fixes: 819671ff849b ("syscalls: define and explain goal to not call syscalls in the kernel")
> Signed-off-by: André Almeida <>

Reviewed-by: Dominik Brodowski <>


 \ /
  Last update: 2021-01-30 10:11    [W:0.040 / U:0.132 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site