[lkml]   [2021]   [Jan]   [26]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH] KVM: update depracated jump label API
On 11/01/21 18:15, Vitaly Kuznetsov wrote:
> kvm_no_apic_vcpu is different, we actually need to increase it with
> every vCPU which doesn't have LAPIC but maybe we can at least switch to
> static_branch_inc()/static_branch_dec(). It is still weird we initialize
> it to 'false'

"kvm_no_apic_vcpu" is badly named. It reads as "true if no vCPU has
APIC" but it means "true if some vCPU has no APIC". The latter is
obviously false in the beginning, because there is no vCPUs at all.

Perhaps a better name would be "kvm_has_noapic_vcpu" (for once,
smashingwordstogether is more readable than the alternative).


but it seems to be a documented behavior. From
> include/linux/jump_label.h:
> "... Thus, static_branch_inc() can be thought of as a 'make more true'
> and static_branch_dec() as a 'make more false'"

 \ /
  Last update: 2021-01-26 19:17    [W:0.135 / U:2.512 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site