lkml.org 
[lkml]   [2020]   [Sep]   [7]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Date
SubjectRe: [PATCH 4/4] ARM: dts: r8a7742-iwg21d-q7: Enable SD2 LED indication
Hi Prabhakar,

On Fri, Sep 4, 2020 at 7:15 PM Lad, Prabhakar
<prabhakar.csengg@gmail.com> wrote:
> On Thu, Sep 3, 2020 at 1:20 PM Geert Uytterhoeven <geert@linux-m68k.org> wrote:
> > On Tue, Aug 25, 2020 at 6:28 PM Lad Prabhakar
> > <prabhakar.mahadev-lad.rj@bp.renesas.com> wrote:
> > > Add support for LED trigger on SD2 interface.
> > >
> > > Signed-off-by: Lad Prabhakar <prabhakar.mahadev-lad.rj@bp.renesas.com>
> > > Reviewed-by: Chris Paterson <Chris.Paterson2@renesas.com>
> >
> > > --- a/arch/arm/boot/dts/r8a7742-iwg21d-q7.dts
> > > +++ b/arch/arm/boot/dts/r8a7742-iwg21d-q7.dts
> > > @@ -63,6 +63,16 @@
> > > enable-gpios = <&gpio3 11 GPIO_ACTIVE_HIGH>;
> > > };
> > >
> > > + leds {
> > > + compatible = "gpio-leds";
> > > +
> > > + sdhi2_led {
> > > + label = "sdio-led";
> > > + gpios = <&gpio5 22 GPIO_ACTIVE_LOW>;
> >
> > GPIO_ACTIVE_HIGH?
> >
> > The LED is driven by an NPN transistor, with the LED between 3.3V and
> > the transistor's collector.

Oops, 3.3V is not VCC_3V3, but SD_3V3, so it is not always-on, but
controlled by SDIO_PWR.

> I did try with GPIO_ACTIVE_HIGH and it didn't work as expected. To
> make sure I can control the LED through sysfs I deleted the node from
> DTS and exported the pin GP5_22 (858) and writing the value "out"
> direction and setting the values 0/1 to value did not toggle the SDIO
> LED as expected and it stayed OFF all the time.

Hence when SDIO_PWR is turned off, you cannot control the LED just by
toggling GP5_22.

> Looks like there is some information missing in the schematics.
>
> I did some experiments. I completely removed the SDHI, LED and
> regulator nodes and booted the system and exported GP1_27 (989) and
> wrote values 0/1 and this toggled the SDIO_LED.
>
> U-boot sets the below, so in u-boot the SDIO_LED is ON:
> gpio_direction_output(GPIO_GP_1_27, 0); /* power on */
> gpio_set_value(GPIO_GP_1_27, 0);
> gpio_direction_output(GPIO_GP_5_22, 0); /* LED */
> gpio_set_value(GPIO_GP_5_22, 1);
> gpio_direction_output(GPIO_GP_1_8, 0); /* 1: 3.3V, 0: 1.8V*/
> gpio_set_value(GPIO_GP_1_8, 1);
>
> So in comparison we would need a hog node as below (and with this the
> LED triggers correctly as expected),
>
> &gpio5 {
> sdio-led-gpio {
> gpio-hog;
> gpios = <22 GPIO_ACTIVE_HIGH>;
> output-high;
> line-name = "sdio-led-gpio";
> };
> };
>
> Let me know if you are OK with the above.

The above means the LED is always lit when SDIO_PWR is enabled.
While I agree that's some kind of SD activity indicator, probably it's less
fine-grained than using the mmc1 trigger?
I assume the mmc1 trigger is only activated when SDIO_PWR is enabled.
Are you sure this doesn't work?
Perhaps your kernel was missing SD trigger support, or "mmc1" is the
wrong SD instance?

> Looks like the SDIO_PWR is tied up with an SDIO_LED pin and the
> information is missing from schematics.

No, I think we just misread the schematics.

Gr{oetje,eeting}s,

Geert

--
Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- geert@linux-m68k.org

In personal conversations with technical people, I call myself a hacker. But
when I'm talking to journalists I just say "programmer" or something like that.
-- Linus Torvalds

\
 
 \ /
  Last update: 2020-09-07 09:56    [W:0.060 / U:1.068 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site