lkml.org 
[lkml]   [2020]   [Sep]   [25]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Date
SubjectRe: [PATCH 5/8] arm64: dts: meson: remove reset-gpios from ethernet node for VIM2 meson-gxm-khadas-vim2
Hi Artem,

(adding back all Cc recipients - please use "reply all" so they don't get lost)

On Fri, Sep 25, 2020 at 10:18 AM Art Nikpal <email2tema@gmail.com> wrote:
>
> this means that "something" is either set up incorrectly in the Linux
> kernel or that u-boot does some magic (and the same magic is then
> missing in the Linux kernel)
>
> maybe ;-)
>
> > I'll dig out my Khadas VIM2 to test this. what should I look out for
> (are there any error messages, dhcp not getting an IP address anymore,
> etc.)?
>
> just start your VIM2 board with ethernet
>
> 1) check connection its must works fine for example try ping your default gw
> 2) do `ifconfig eth0 down`
> 3) do `ifconfig eth0 up`
> 4) check your connection again it will be broken and u cant restore it im sure ;-) only reboot
# ping -4 -c2 google.com && ifconfig eth0 down && ifconfig eth0 up &&
sleep 5s && ping -4 -c2 google.com
PING google.com (172.217.22.78) 56(84) bytes of data.
64 bytes from fra15s17-in-f14.1e100.net (172.217.22.78): icmp_seq=1
ttl=114 time=22.4 ms
64 bytes from fra15s17-in-f78.1e100.net (172.217.22.78): icmp_seq=2
ttl=114 time=22.5 ms

--- google.com ping statistics ---
2 [ 127.097495] meson8b-dwmac c9410000.ethernet eth0: Link is Down
packets transmitted, 2 received, 0% packet loss, time 1002ms
rtt min/avg/max/mdev = 22.375/22.415/22.455/0.040 ms
[ 127.170167] meson8b-dwmac c9410000.ethernet eth0: PHY
[0.2009087f:00] driver [RTL8211F Gigabit Ethernet] (irq=38)
[ 127.276459] meson8b-dwmac c9410000.ethernet eth0: No Safety
Features support found
[ 127.278508] meson8b-dwmac c9410000.ethernet eth0: PTP not supported by HW
[ 127.285230] meson8b-dwmac c9410000.ethernet eth0: configuring for
phy/rgmii link mode
[ 130.425311] meson8b-dwmac c9410000.ethernet eth0: Link is Up -
1Gbps/Full - flow control rx/tx
PING google.com (172.217.22.78) 56(84) bytes of data.
64 bytes from fra15s17-in-f14.1e100.net (172.217.22.78): icmp_seq=1
ttl=114 time=22.4 ms
64 bytes from fra15s17-in-f78.1e100.net (172.217.22.78): icmp_seq=2
ttl=114 time=22.6 ms

--- google.com ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 1002ms
rtt min/avg/max/mdev = 22.439/22.512/22.585/0.073 ms

note: the sleep 5s is needed to allow the link to come back up and to
get an IP address via DHCP
also if the output is not easy to read in your email client then I
have also uploaded it here: [0]

can you please show me the output of the debug logs in
rtl8211f_config_init() from drivers/net/phy/realtek.c (for example by
replacing dev_dbg with dev_err)?


Best regards,
Martin


[0] https://curlpaste.com/web/eaqun7

\
 
 \ /
  Last update: 2020-09-25 13:27    [W:0.048 / U:0.732 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site