lkml.org 
[lkml]   [2020]   [Sep]   [24]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 2/3] HID: rmi - rename f30_data to gpio_data
On Thu, 24 Sep 2020, Vincent Huang wrote:

> f30_data in rmi_device_platform_data could be also referenced by RMI
> function 3A, so rename it and the structure name to avoid confusion.
>
> Signed-off-by: Vincent Huang <vincent.huang@tw.synaptics.com>
> ---
> drivers/hid/hid-rmi.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/hid/hid-rmi.c b/drivers/hid/hid-rmi.c
> index 9ce22acdfaca..62315e31d520 100644
> --- a/drivers/hid/hid-rmi.c
> +++ b/drivers/hid/hid-rmi.c
> @@ -722,7 +722,7 @@ static int rmi_probe(struct hid_device *hdev, const struct hid_device_id *id)
> }
>
> if (data->device_flags & RMI_DEVICE_HAS_PHYS_BUTTONS)
> - rmi_hid_pdata.f30_data.disable = true;
> + rmi_hid_pdata.gpio_data.disable = true;
>
> data->xport.dev = hdev->dev.parent;
> data->xport.pdata = rmi_hid_pdata;

Please fold this into the first patch; this way you break bisectability.

Thanks,

--
Jiri Kosina
SUSE Labs

\
 
 \ /
  Last update: 2020-09-24 16:53    [W:0.083 / U:2.292 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site