Messages in this thread |  | | Date | Fri, 10 Jul 2020 13:32:38 +0200 | From | Peter Zijlstra <> | Subject | Re: [PATCH RFC] kprobes: Remove MODULES dependency |
| |
On Fri, Jul 10, 2020 at 07:32:57PM +0900, Masami Hiramatsu wrote: > > - page = module_alloc(PAGE_SIZE); > > + page = vmalloc(PAGE_SIZE); > > No, you can not use vmalloc here. The reason why we use module_alloc() > is to allocate the executable memory for trampoline code. > So, you need to use vmalloc_exec() instead.
vmalloc_exec() would be broken too, also hch recently got rid of that thing.
module_alloc() really is the only sane choice here.
We should make module_alloc() unconditionally available, and maybe even rename it to text_alloc().
|  |