lkml.org 
[lkml]   [2020]   [Jun]   [13]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Date
SubjectRe: [PATCH] ARM: dts: omap3: Migrate AES from hwmods to sysc-omap2
On Tue, May 5, 2020 at 6:34 PM Tony Lindgren <tony@atomide.com> wrote:
>
> * Adam Ford <aford173@gmail.com> [200505 21:18]:
> > On Tue, May 5, 2020 at 1:42 PM Tony Lindgren <tony@atomide.com> wrote:
> > >
> > > * Adam Ford <aford173@gmail.com> [200504 16:02]:
> > > > Various OMAP3 boards have two AES blocks, but only one is currently
> > > > available, because the hwmods are only configured for one.
> > > >
> > > > This patch migrates the hwmods for the AES engine to sysc-omap2
> > > > which allows the second AES crypto engine to become available.
> > > >
> > > > omap-aes 480a6000.aes1: OMAP AES hw accel rev: 2.6
> > > > omap-aes 480a6000.aes1: will run requests pump with realtime priority
> > > > omap-aes 480c5000.aes2: OMAP AES hw accel rev: 2.6
> > > > omap-aes 480c5000.aes2: will run requests pump with realtime priority
> > >
> > > Great :) Looks like I'm getting the following though:
> > >
> > > DTC arch/arm/boot/dts/am3517-craneboard.dtb
> > > arch/arm/boot/dts/omap3.dtsi:160.39-184.5: ERROR (phandle_references):
> > > /ocp@68000000/target-module@480a6000:
> > > Reference to non-existent node or label "aes1_ick"
> > >
> > > Is this patch maybe missing a change for am3717 for the aes1_ick?
> >
> > I am guessing it's the same issue that plagues the am3517 with a note
> > in the hwmods that stated noone seems to know which am3517's support
> > it and which don't. The RNG was disabled on the 3517, so I am
> > guessing I'll do the same for AES.
>
> OK, I have no idea what modules might be there on am3517.

I'm going to repost a V2 with the node removed on am3517.

>
> > I should have posted it as an RFC, because I don't have the proper IRQ
> > setup for the newly supported AES engine. The interrupts that are
> > used for the original AES are listed as 'Reserved' in the AM3517 TRM.

Through trial and error, I think I have the right IRQ for OMAP3630 for
the 2nd instance.

> > I assume the second engine uses different interrupts. I don't suppose
> > anyone know what it should be?
>
> Sorry no idea, usually the secure accelerator documentation is just
> left out it seems. My guess the values are the same as on omap3.

Tony - Could you review the hwmod transition I did for the first
engine to make sure I did it right?

If you think I did it right, I'll post my V2.

adam
>
> Regards,
>
> Tony

\
 
 \ /
  Last update: 2020-06-13 13:11    [W:0.043 / U:1.040 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site