lkml.org 
[lkml]   [2020]   [Apr]   [15]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH v10 18/55] Input: atmel_mxt_ts: Rename mxt_hw_version_show to hw_version_show
From
Date
Hi Dmitry

On 2020/04/11 6:46, Dmitry Osipenko wrote:
> 31.03.2020 13:50, Jiada Wang пишет:
>> Rename mxt_hw_version_show to hw_version_show to address checkpatch warning
>>
>> Signed-off-by: Jiada Wang <jiada_wang@mentor.com>
>> ---
>> drivers/input/touchscreen/atmel_mxt_ts.c | 6 +++---
>> 1 file changed, 3 insertions(+), 3 deletions(-)
>>
>> diff --git a/drivers/input/touchscreen/atmel_mxt_ts.c b/drivers/input/touchscreen/atmel_mxt_ts.c
>> index b2a37a9597f3..cec823de4096 100644
>> --- a/drivers/input/touchscreen/atmel_mxt_ts.c
>> +++ b/drivers/input/touchscreen/atmel_mxt_ts.c
>> @@ -3114,8 +3114,8 @@ static ssize_t fw_version_show(struct device *dev,
>> }
>>
>> /* Hardware Version is returned as FamilyID.VariantID */
>> -static ssize_t mxt_hw_version_show(struct device *dev,
>> - struct device_attribute *attr, char *buf)
>> +static ssize_t hw_version_show(struct device *dev,
>> + struct device_attribute *attr, char *buf)
>> {
>> struct mxt_data *data = dev_get_drvdata(dev);
>> struct mxt_info *info = data->info;
>> @@ -3404,7 +3404,7 @@ static const struct attribute_group mxt_fw_attr_group = {
>> };
>>
>> static DEVICE_ATTR_RO(fw_version);
>> -static DEVICE_ATTR(hw_version, S_IRUGO, mxt_hw_version_show, NULL);
>> +static DEVICE_ATTR_RO(hw_version);
>> static DEVICE_ATTR(object, S_IRUGO, mxt_object_show, NULL);
>
> What about to add a patch to convert the mxt_object_show to
> DEVICE_ATTR_RO(object_show)?
>
sure, mxt_object, is the last attr not using DEVICE_ATTR_[RO|WO|RW],
I will add another commit to update in next version

Thanks,
Jiada

\
 
 \ /
  Last update: 2020-04-15 15:13    [W:9.787 / U:2.304 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site