lkml.org 
[lkml]   [2020]   [Mar]   [11]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [f2fs-dev] Writes stoped working on f2fs after the compression support was added
Hello,

On Wed, Mar 11, 2020 at 05:02:10PM +0800, Chao Yu wrote:
> Hi,
>
> Sorry for the delay.
>
> On 2020/3/6 20:02, Ondřej Jirman wrote:
> > Hello,
> >
> > On Thu, Feb 27, 2020 at 10:01:50AM +0800, Chao Yu wrote:
> >> On 2020/2/27 2:05, Ondřej Jirman wrote:
> >>>
> >>> No issue after 7h uptime either. So I guess this patch solved it for some
> >>> reason.
> >>
> >> I hope so as well, I will send a formal patch for this.
> >
> > So I had it happen again, even with the patches. This time in f2fs_rename2:
>
> Oops, it looks previous fix patch just cover the root cause... :(
>
> Did this issue still happen frequently? If it is, would you please apply patch
> that prints log during down/up semaphore.

Not frequently. Just once. I couldn't afford FS corruption during update,
so I reverted the compression support shortly after.

But I wasn't stressing the system much with FS activity after applying the
initial fix.

> And once we revert compression support patch, this issue will disappear, right?

Yes, AFAIK. I reverted it and run a few cycles of install 500MiB worth of
packages, uninstall the packages with pacman. And it didn't re-occur. I never
saw any issues with compression support patch reverted.

> Btw, did you try other hardware which is not Arm v7?

Yes, but I didn't ever see it on anything else. Just on two 8 core cortexes A7.
(2 clusters)

regards,
o.

\
 
 \ /
  Last update: 2020-03-11 11:33    [W:0.102 / U:8.392 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site