lkml.org 
[lkml]   [2020]   [Feb]   [6]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH v4 2/8] dt-bindings: phy: qcom,qusb2: Add compatibles for QUSB2 V2 phy and SC7180
On Wed, Jan 29, 2020 at 07:21:53PM +0530, Sandeep Maheswaram wrote:
> Add compatibles for generic QUSB2 V2 phy which can be used for
> sdm845 and sc7180.
>
> Signed-off-by: Sandeep Maheswaram <sanm@codeaurora.org>
> ---
> Documentation/devicetree/bindings/phy/qcom,qusb2-phy.yaml | 15 +++++++++++----
> 1 file changed, 11 insertions(+), 4 deletions(-)
>
> diff --git a/Documentation/devicetree/bindings/phy/qcom,qusb2-phy.yaml b/Documentation/devicetree/bindings/phy/qcom,qusb2-phy.yaml
> index 90b3cc6..43082c8 100644
> --- a/Documentation/devicetree/bindings/phy/qcom,qusb2-phy.yaml
> +++ b/Documentation/devicetree/bindings/phy/qcom,qusb2-phy.yaml
> @@ -15,10 +15,17 @@ description:
>
> properties:
> compatible:
> - enum:
> - - qcom,msm8996-qusb2-phy
> - - qcom,msm8998-qusb2-phy
> - - qcom,sdm845-qusb2-phy
> + oneOf:
> + - items:

You can omit 'items' here.

> + - enum:
> + - qcom,msm8996-qusb2-phy
> + - qcom,msm8998-qusb2-phy
> + - qcom,qusb2-v2-phy

This should not be valid alone. An SoC specific compatible is required.

> + - items:
> + - enum:
> + - qcom,sc7180-qusb2-phy
> + - qcom,sdm845-qusb2-phy
> + - const: qcom,qusb2-v2-phy

Is your intention that qcom,sdm845-qusb2-phy alone is no longer valid?

Rob

> reg:
> maxItems: 1
>
> --
> QUALCOMM INDIA, on behalf of Qualcomm Innovation Center, Inc. is a member
> of Code Aurora Forum, hosted by The Linux Foundation
>

\
 
 \ /
  Last update: 2020-02-06 21:46    [W:0.125 / U:1.752 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site