[lkml]   [2020]   [Feb]   [29]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH v2 06/18] m68k: Replace setup_irq() by request_irq()

v3 has been posted w/ following changes,

1. Avoid unnecessary derefencing w.r.t irq name in pr_err
2. Modify pr_err() string so as to display in the form similar to,
"Failed to request irq 2 (cascade)"
3. More commit message massage

Above are based on tglx feedback & would be applied to all patches in
addition to rearranging as required in other patches for readability.

Specific to m68k, following changes has been made based on m68 family
;) feedback,

1. Catch the errror code & display the symbolic error name usin "%pe"
format specifier
2. irq # in pr_err (already covered by following pt 2 pattern above)
3. s/pr_err/pr_debug

No altering of control flow based on error value has been done.


 \ /
  Last update: 2020-02-29 14:16    [W:8.159 / U:0.684 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site