lkml.org 
[lkml]   [2020]   [Feb]   [27]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH v4 13/13] powerpc/ptrace: move ptrace triggered() into hw breakpoint.c
This was my fault, I should really test changes like these before they go live.  Apologies for the confusion caused

--
Russell Currey
ruscur@russell.cc

On Fri, Feb 28, 2020, at 2:59 PM, Andrew Donnellan wrote:
> On 28/2/20 9:16 am, Michael Ellerman wrote:
> > Christophe Leroy <christophe.leroy@c-s.fr> writes:
> >> Russel,
> >>
> >> Le 27/02/2020 à 12:49, Christophe Leroy a écrit :
> >>> ptrace_triggered() is declared in asm/hw_breakpoint.h and
> >>> only needed when CONFIG_HW_BREAKPOINT is set, so move it
> >>> into hw_breakpoint.c
> >>
> >> My series v4 is definitely buggy (I included ptrace_decl.h instead
> >> instead of ptrace-decl.h), how can Snowpatch say build succeeded
> >> (https://patchwork.ozlabs.org/patch/1245807/) ?
> >
> > Which links to:
> > https://openpower.xyz/job/snowpatch/job/snowpatch-linux-sparse/15895//artifact/linux/report.txt
> >
> > The actual build log of which is:
> > https://openpower.xyz/job/snowpatch/job/snowpatch-linux-sparse/15895/artifact/linux/build_new.log
> >
> > Which contains:
> > scripts/Makefile.build:267: recipe for target 'arch/powerpc/kernel/ptrace/ptrace-altivec.o' failed
> > make[3]: *** [arch/powerpc/kernel/ptrace/ptrace-altivec.o] Error 1
> > make[3]: *** Waiting for unfinished jobs....
> > scripts/Makefile.build:505: recipe for target 'arch/powerpc/kernel/ptrace' failed
> > make[2]: *** [arch/powerpc/kernel/ptrace] Error 2
> > make[2]: *** Waiting for unfinished jobs....
> > scripts/Makefile.build:505: recipe for target 'arch/powerpc/kernel' failed
> > make[1]: *** [arch/powerpc/kernel] Error 2
> > make[1]: *** Waiting for unfinished jobs....
> > Makefile:1681: recipe for target 'arch/powerpc' failed
> > make: *** [arch/powerpc] Error 2
> > make: *** Waiting for unfinished jobs....
> >
> > Same for ppc64le:
> > https://openpower.xyz/job/snowpatch/job/snowpatch-linux-sparse/15896/artifact/linux/build_new.log
> >
> >
> > So it seems like snowpatch always reports the build as succeeded even
> > when it fails.
>
> Turns out there was an issue in a recent change in our build script
> which caused build failures to return the wrong exit code and put the
> wrong text in the reports, because of some confusion with bash
> subshells. I've fixed it (I think).
>
> --
> Andrew Donnellan OzLabs, ADL Canberra
> ajd@linux.ibm.com IBM Australia Limited
>
>

\
 
 \ /
  Last update: 2020-02-28 05:03    [W:0.069 / U:0.048 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site