[lkml]   [2020]   [Feb]   [12]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH v4 3/3] selftests: KVM: SVM: Add vmcall test
On 07/02/20 11:15, Auger Eric wrote:
>> Probably rename the file to svm_nested_vmcall_test.c. This matches with
>> the naming convention of VMX's nested tests. Otherwise people might not know
>> it is a nested one.
> From what I understand, all the vmx_* (including vmx_tsc_adjust_test for
> instance) are related to nested. So I'd rather leave svm_ prefix for
> nested SVM.

That is not strictly necessary, as there could be tests for Intel or
AMD-specific bugs or features. But in practice you are right, "vmx_"
right now means it's testing nested. We can rename all of them to
"nvmx_*" and "nsvm_*", but in the meanwhile your patch does not
introduce any inconsistency.

Queued, thanks!


 \ /
  Last update: 2020-02-12 12:44    [W:0.103 / U:7.124 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site