[lkml]   [2020]   [Feb]   [12]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
Subject[PATCH 0/1] rpmsg: core: Add wildcard match for name service
This patch is the newest iteration of a feature that has been explored in
the past by Xiang[1] and Suman[2]. It was also deemed useful by Arnaud.

I have decided to use a new approach to avoid potential code duplication
that may happen with the introduction of an rpdev->match() and reduce the
footprint inherent from the addition of an additional description field.

I'm sending this out to restart the conversation on the best way to move
forward with this feature.

I have tested this on ST's mp157c-ev1 board - the kernel was enhanced but
MCU image remained unchanged, proving backward compatibility with the
current implementation.


Mathieu Poirier (1):
rpmsg: core: Add wildcard match for name service

drivers/rpmsg/rpmsg_core.c | 20 +++++++++++++++++++-
1 file changed, 19 insertions(+), 1 deletion(-)


 \ /
  Last update: 2020-02-12 22:13    [W:0.046 / U:0.304 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site