lkml.org 
[lkml]   [2020]   [Nov]   [7]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 41/41] realtek: rtw88: pci: Add prototypes for .probe, .remove and .shutdown
On Sat, 07 Nov 2020, Kalle Valo wrote:

> Lee Jones <lee.jones@linaro.org> writes:
>
> > On Mon, 02 Nov 2020, Brian Norris wrote:
> >
> >> On Mon, Nov 2, 2020 at 3:25 AM Lee Jones <lee.jones@linaro.org> wrote:
> >> > --- a/drivers/net/wireless/realtek/rtw88/pci.h
> >> > +++ b/drivers/net/wireless/realtek/rtw88/pci.h
> >> > @@ -212,6 +212,10 @@ struct rtw_pci {
> >> > void __iomem *mmap;
> >> > };
> >> >
> >> > +int rtw_pci_probe(struct pci_dev *pdev, const struct pci_device_id *id);
> >> > +void rtw_pci_remove(struct pci_dev *pdev);
> >> > +void rtw_pci_shutdown(struct pci_dev *pdev);
> >> > +
> >> >
> >>
> >> These definitions are already in 4 other header files:
> >>
> >> drivers/net/wireless/realtek/rtw88/rtw8723de.h
> >> drivers/net/wireless/realtek/rtw88/rtw8821ce.h
> >> drivers/net/wireless/realtek/rtw88/rtw8822be.h
> >> drivers/net/wireless/realtek/rtw88/rtw8822ce.h
> >>
> >> Seems like you should be moving them, not just adding yet another duplicate.
> >
> > I followed the current convention.
> >
> > Happy to optimise if that's what is required.
>
> I agree with Brian, these and rtw_pm_ops should be moved to pci.h to
> avoid code duplication.

Will do, thanks.

--
Lee Jones [李琼斯]
Senior Technical Lead - Developer Services
Linaro.org │ Open source software for Arm SoCs
Follow Linaro: Facebook | Twitter | Blog

\
 
 \ /
  Last update: 2020-11-07 19:43    [W:0.059 / U:2.928 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site