lkml.org 
[lkml]   [2020]   [Nov]   [6]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 00/23] Rid W=1 warnings in MTD
Hi Lee,

Lee Jones <lee.jones@linaro.org> wrote on Fri, 6 Nov 2020 13:32:47
+0000:

> > This set is part of a larger effort attempting to clean-up W=1
> > kernel builds, which are currently overwhelmingly riddled with
> > niggly little warnings.
> >
> > Lee Jones (23):
> > mtd: mtdpart: Fix misdocumented function parameter 'mtd'
> > mtd: devices: phram: File headers are not good candidates for
> > kernel-doc
> > mtd: nand: onenand: onenand_base: Fix expected kernel-doc formatting
> > mtd: devices: docg3: Fix kernel-doc 'bad line' and 'excessive doc'
> > issues
> > mtd: mtdcore: Fix misspelled function parameter 'section'
> > mtd: nand: onenand: onenand_bbt: Fix expected kernel-doc formatting
> > mtd: spi-nor: controllers: hisi-sfc: Demote non-conformant kernel-doc
> > mtd: ubi: build: Document 'ubi_num' in struct mtd_dev_param
> > mtd: nand: spi: toshiba: Demote non-conformant kernel-doc header
> > mtd: ubi: kapi: Correct documentation for 'ubi_leb_read_sg's 'sgl'
> > parameter
> > mtd: ubi: eba: Fix a couple of misdocumentation issues
> > mtd: ubi: wl: Fix a couple of kernel-doc issues
> > mtd: nand: raw: brcmnand: brcmnand: Demote non-conformant kernel-doc
> > headers
> > mtd: ubi: gluebi: Fix misnamed function parameter documentation
> > mtd: nand: raw: diskonchip: Marking unused variables as
> > __always_unused
> > mtd: nand: raw: cafe_nand: Remove superfluous param doc and add
> > another
> > mtd: nand: raw: s3c2410: Add documentation for 2 missing struct
> > members
> > mtd: nand: raw: omap_elm: Finish half populated function header,
> > demote empty ones
> > mtd: nand: raw: omap2: Fix a bunch of kernel-doc misdemeanours
> > mtd: nand: raw: sunxi_nand: Document 'sunxi_nfc's 'caps' member
> > mtd: nand: raw: arasan-nand-controller: Document 'anfc_op's 'buf'
> > member
> > mtd: nand: onenand: onenand_base: Fix some kernel-doc misdemeanours
> > mtd: devices: powernv_flash: Add function names to headers and fix
> > 'dev'
>
> May I ask; what is the plan for these patches please?
>
> Do you plan on taking the ones that do not require re-work, rather
> than fixing up and re-submitting the whole set. It would certainly
> save a lot of mailing list churn if that were the case.
>
> Either way, let me know and I will abide by your decision.
>

I would prefer receiving a v2 with all the patches if you don't mind.

Thanks,
Miquèl

\
 
 \ /
  Last update: 2020-11-06 14:44    [W:0.174 / U:0.656 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site