lkml.org 
[lkml]   [2020]   [Nov]   [2]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: Linux 5.10-rc2 (docs build)
Em Mon, 2 Nov 2020 11:23:25 -0800
Randy Dunlap <rdunlap@infradead.org> escreveu:

> On 11/2/20 8:59 AM, Mauro Carvalho Chehab wrote:
> > Em Mon, 2 Nov 2020 08:02:34 -0800
> > Randy Dunlap <rdunlap@infradead.org> escreveu:
> >
> >> On 11/2/20 12:33 AM, Mauro Carvalho Chehab wrote:
> >>> Em Mon, 2 Nov 2020 08:58:41 +0100
> >>> Mauro Carvalho Chehab <mchehab@kernel.org> escreveu:
> >>>
> >>>> Hi Randy,
> >>>>
> >>>> Em Sun, 1 Nov 2020 16:01:54 -0800
> >>>> Randy Dunlap <rdunlap@infradead.org> escreveu:
> >>>>
> >>>>> Something broke the docs build (SEVERE):
> >>>>>
> >>>>>
> >>>>> Sphinx parallel build error:
> >>>>> docutils.utils.SystemMessage: /home/rdunlap/lnx/lnx-510-rc2/Documentation/ABI/testing/sysfs-bus-rapidio:2: (SEVERE/4) Title level inconsistent:
> >>>>>
> >>>>> Attributes Common for All RapidIO Devices
> >>>>> -----------------------------------------
> >>>>>
> >>>>>
> >>>>
> >>>> On what tree did you notice this? Linux-next or upstream?
> >>
> >> See $Subject: 5.10-rc2
> >>
> >>
> >>> Also: on what Sphinx version are you getting it? I'm not
> >>> able to reproduce the issue here, neither with Sphinx 2.4.4
> >>> nor with Sphinx 3.2.1.
> >>
> >> That could be one source of the problem: ;)
> >>
> >> from my docs build:
> >>
> >> Sphinx version: 1.7.6
> >> Warning: It is recommended at least Sphinx version 1.7.9.
> >> If you want pdf, you need at least 2.4.4.
> >
> > Could be... From 1.7.6 to 1.7.9, there were bug fixes ;-)
> >
> > Also, on Sphinx, they stop maintaining old versions once newer
> > stable ones are launched. So, any bug on 1.7.x (up to 3.2.x) will
> > remain unfixed[1].
> >
> > In any case, could you please check if this patch solves the
> > issue?
> >
> > https://lore.kernel.org/lkml/6c62ef5c01d39dee8d891f8390c816d2a889670a.1604312590.git.mchehab+huawei@kernel.org/
>
> Nope, sorry, with that patch applied to v5.10-rc2, I get:
>
> reading sources... [ 93%] userspace-api/media/v4l/pixfmt-y8i .. userspace-api/media/v4l/vidioc-querybuf
> reading sources... [ 96%] userspace-api/media/v4l/vidioc-querycap .. vm/transhuge
> reading sources... [100%] vm/unevictable-lru .. xtensa/mmu
>
> waiting for workers...
>
> {hangs; enter ^C}
>
> Sphinx parallel build error:
> docutils.utils.SystemMessage: /home/rdunlap/lnx/lnx-510-rc2/Documentation/ABI/testing/sysfs-class-led-trigger-pattern.orig:16: (SEVERE/4) Unexpected section title.

Hmm...
sysfs-class-led-trigger-pattern.orig

That doesn't sound right! It seems you have a backup of an old file
there ;-)

-

In order to double-check, I tested it here with:

$ /usr/bin/python3 -m venv sphinx_1.7.6
$ pip install docutils sphinx_rtd_theme Sphinx==1.7.6
$ pip install docutils==0.15 sphinx_rtd_theme Sphinx==1.7.6


And then built the docs with:

$ time make O="sphinx1.7" SPHINXOPTS="-w new_warnings --no-color" cleandocs htmldocs

Everything build fine (except for a huge amount of warnings that seem
to indicate some bug at the cross-reference logic with 1.7.6).

<snip>
make[1]: Entering directory '/devel/v4l/docs/sphinx1.7'
rm -f /devel/v4l/docs/sphinx1.7/Documentation/output/audio.h.rst /devel/v4l/docs/sphinx1.7/Documentation/output/ca.h.rst /devel/v4l/docs/sphinx1.7/Documentation/output/dmx.h.rst /devel/v4l/docs/sphinx1.7/Documentation/output/frontend.h.rst /devel/v4l/docs/sphinx1.7/Documentation/output/net.h.rst /devel/v4l/docs/sphinx1.7/Documentation/output/video.h.rst /devel/v4l/docs/sphinx1.7/Documentation/output/videodev2.h.rst /devel/v4l/docs/sphinx1.7/Documentation/output/media.h.rst /devel/v4l/docs/sphinx1.7/Documentation/output/cec.h.rst /devel/v4l/docs/sphinx1.7/Documentation/output/lirc.h.rst 2>/dev/null
Detected OS: Ubuntu 20.04.1 LTS.
Sphinx version: 1.7.6

Warning: It is recommended at least Sphinx version 1.7.9.
If you want pdf, you need at least 2.4.4.
Note: It is recommended at least Sphinx version 2.4.4 if you need PDF support.
To upgrade Sphinx, use:

/devel/v4l/docs/sphinx_1.7.6/bin/python3 -m venv sphinx_2.4.4
. sphinx_2.4.4/bin/activate
pip install -r ../Documentation/sphinx/requirements.txt

If you want to exit the virtualenv, you can use:
deactivate

All optional dependencies are met.
Needed package dependencies are met.
SPHINX htmldocs --> file:///devel/v4l/docs/sphinx1.7/Documentation/output
PARSE include/uapi/linux/dvb/audio.h
PARSE include/uapi/linux/dvb/ca.h
PARSE include/uapi/linux/dvb/dmx.h
PARSE include/uapi/linux/dvb/frontend.h
PARSE include/uapi/linux/dvb/net.h
PARSE include/uapi/linux/dvb/video.h
PARSE include/uapi/linux/videodev2.h
PARSE include/uapi/linux/media.h
PARSE include/uapi/linux/lirc.h
PARSE include/uapi/linux/cec.h
Running Sphinx v1.7.6
...
copying static files... done
copying extra files... done
dumping search index in English (code: en) ... done
dumping object inventory... done
build succeeded, 767 warnings.

The HTML pages are in Documentation/output.
make[1]: Leaving directory '/devel/v4l/docs/sphinx1.7'

real 2m31.798s
user 9m39.494s
sys 0m38.300s
</snip>

The only output difference is the huge amount of warnings (767 warnings
with this version, against 24 when built with 2.4.4).

Thanks,
Mauro

\
 
 \ /
  Last update: 2020-11-02 21:36    [W:0.078 / U:0.864 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site