[lkml]   [2020]   [Oct]   [7]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH 1/2] cpufreq,arm,arm64: restructure definitions of arch_set_freq_scale()
On Thu, Sep 24, 2020 at 01:30:15PM +0100, Ionela Voinescu wrote:
> Compared to other arch_* functions, arch_set_freq_scale() has an atypical
> weak definition that can be replaced by a strong architecture specific
> implementation.
> The more typical support for architectural functions involves defining
> an empty stub in a header file if the symbol is not already defined in
> architecture code. Some examples involve:
> - #define arch_scale_freq_capacity topology_get_freq_scale
> - #define arch_scale_freq_invariant topology_scale_freq_invariant
> - #define arch_scale_cpu_capacity topology_get_cpu_scale
> - #define arch_update_cpu_topology topology_update_cpu_topology
> - #define arch_scale_thermal_pressure topology_get_thermal_pressure
> - #define arch_set_thermal_pressure topology_set_thermal_pressure
> Bring arch_set_freq_scale() in line with these functions by renaming it to
> topology_set_freq_scale() in the arch topology driver, and by defining the
> arch_set_freq_scale symbol to point to the new function for arm and arm64.
> While there are other users of the arch_topology driver, this patch defines
> arch_set_freq_scale for arm and arm64 only, due to their existing
> definitions of arch_scale_freq_capacity. This is the getter function of the
> frequency invariance scale factor and without a getter function, the
> setter function - arch_set_freq_scale() has not purpose.
> Signed-off-by: Ionela Voinescu <>
> Cc: Russell King <>
> Cc: Catalin Marinas <>
> Cc: Will Deacon <>

For the arm64 changes:

Acked-by: Catalin Marinas <>

 \ /
  Last update: 2020-10-07 17:22    [W:0.104 / U:1.452 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site