[lkml]   [2020]   [Oct]   [28]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH v3] mm/oom_kill: remove comment and rename is_dump_unreclaim_slabs()
On Wed, 28 Oct 2020 23:31:41 +0800 Hui Su <> wrote:

> Comment for is_dump_unreclaim_slabs is not really clear whether it is
> meant to instruct how to use the function or whether it is an outdated
> information of the past implementation of the function. it doesn't realy
> help that is_dump_unreclaim_slabs is hard to grasp on its own.
> Rename the helper to should_dump_unreclaim_slabs which should make it
> clear what it is meant to do and drop the comment as the purpose
> should be pretty evident now.

I think your recent attempt to improve the comment:

* Check whether unreclaimable slabs amount is greater than all user
* memory(LRU pages).

was actually somewhat useful, and worth retaining.

It would be better if it explained *why* we're doing this, rather than
simply "what we are doing"?

<looks at the code>

It's actually quite unobvious why we're doing this!

 \ /
  Last update: 2020-10-28 23:09    [W:0.068 / U:0.408 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site