Messages in this thread |  | | Date | Thu, 09 Jan 2020 11:22:21 +0800 | From | Rocky Liao <> | Subject | Re: [PATCH v2 1/3] Bluetooth: hci_qca: Add qca_power_on() API to support both wcn399x and Rome power up |
| |
Hi Matt,
在 2020-01-09 02:34,Matthias Kaehlcke 写道: > Hi Rocky, > > On Wed, Jan 08, 2020 at 05:08:02PM +0800, Rocky Liao wrote: >> This patch adds a unified API qca_power_on() to support both wcn399x >> and >> Rome power on. For wcn399x it calls the qca_wcn3990_init() to init the >> regulators, and for Rome it pulls up the bt_en GPIO to power up the >> btsoc. >> >> Signed-off-by: Rocky Liao <rjliao@codeaurora.org> >> --- >> >> Changes in v2: None >> >> drivers/bluetooth/hci_qca.c | 21 +++++++++++++++++++++ >> 1 file changed, 21 insertions(+) >> >> diff --git a/drivers/bluetooth/hci_qca.c b/drivers/bluetooth/hci_qca.c >> index 9392cc7f9908..f6555bd1adbc 100644 >> --- a/drivers/bluetooth/hci_qca.c >> +++ b/drivers/bluetooth/hci_qca.c >> @@ -1532,6 +1532,27 @@ static int qca_wcn3990_init(struct hci_uart >> *hu) >> return 0; >> } >> >> +static int qca_power_on(struct hci_dev *hdev) >> +{ >> + struct hci_uart *hu = hci_get_drvdata(hdev); >> + enum qca_btsoc_type soc_type = qca_soc_type(hu); >> + struct qca_serdev *qcadev; >> + int ret = 0; >> + >> + if (qca_is_wcn399x(soc_type)) { > > Why not include the qca_regulator_enable() call from qca_open() here? > It is clearly part of power on. > OK
>> + ret = qca_wcn3990_init(hu); >> + } else { >> + if (hu->serdev) { > > nit: you could save a level of indentation (and IMO improve > readability) by doing: > > if (!hu->serdev) > return 0; > OK
>> + qcadev = serdev_device_get_drvdata(hu->serdev); >> + gpiod_set_value_cansleep(qcadev->bt_en, 1); >> + /* Controller needs time to bootup. */ >> + msleep(150); >> + } >> + } >> + >> + return ret; >> +} >> + > > I think common practice would be to combine the 3 patches of this > series > into one. The new function doesn't really add any new functionality, > but > is a refactoring. This is more evident if you see in a single diff that > the pieces in qca_power_on() are removed elsewhere. OK
|  |