[lkml]   [2020]   [Jan]   [11]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [v3] coccinelle: semantic patch to check for inappropriate do_div() calls
>> * I suggest once more to adjust the dependency specifications for the usage
>>   of these functions by SmPL rules.
> Most of the functions here are for all operation modes.

I got an other understanding for this software.

You added the information “also filter out safe consts for context mode”
to the patch change log.

>> * Can the local variable “msg” be omitted?

I would appreciate another fine-tuning also at this place.

>>>[0], construct_warnings("div64_ul"))
>> I suggest again to move the prefix “div64_” into the string literal
>> of the function implementation.
> “div64_ul” indicates the function name we recommend.

The intention can be fine.

> If we delete the prefix "div64_",

I suggest to use the text at an other place.

> it may reduce readability.

I find an other code variant also readable good enough.

> +*do_div(f, \( l \| ul \| ul64 \| sl64 \) );
> We agree with Julia:
> I don't se any point to this.

Can the avoidance of duplicate source code (according to SmPL disjunctions)
trigger positive effects on run time characteristics and software maintenance?


 \ /
  Last update: 2020-01-11 08:31    [W:0.054 / U:0.704 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site