lkml.org 
[lkml]   [2019]   [Sep]   [9]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: [PATCH v3 2/4] clk: qcom: clk-rpmh: Convert to parent data scheme
Date
Quoting Vinod Koul (2019-08-25 23:21:27)
> On 23-08-19, 23:31, Bjorn Andersson wrote:
> > On Thu 22 Aug 10:01 PDT 2019, Vinod Koul wrote:
> >
> > > Convert the rpmh clock driver to use the new parent data scheme by
> > > specifying the parent data for board clock.
> > >
> > > Signed-off-by: Vinod Koul <vkoul@kernel.org>
> > > ---
> > > drivers/clk/qcom/clk-rpmh.c | 10 ++++++++--
> > > 1 file changed, 8 insertions(+), 2 deletions(-)
> > >
> > > diff --git a/drivers/clk/qcom/clk-rpmh.c b/drivers/clk/qcom/clk-rpmh.c
> > > index c3fd632af119..0bced7326a20 100644
> > > --- a/drivers/clk/qcom/clk-rpmh.c
> > > +++ b/drivers/clk/qcom/clk-rpmh.c
> > > @@ -95,7 +95,10 @@ static DEFINE_MUTEX(rpmh_clk_lock);
> > > .hw.init = &(struct clk_init_data){ \
> > > .ops = &clk_rpmh_ops, \
> > > .name = #_name, \
> > > - .parent_names = (const char *[]){ "xo_board" }, \
> > > + .parent_data = &(const struct clk_parent_data){ \
> > > + .fw_name = "xo_board", \
> > > + .name = "xo_board", \
> >
> > Iiuc .name here refers to the global clock namespace and .fw_name refers
> > to the device_node local name space. As such I really prefer this to be:
> >
> > .fw_name = "xo",
> > .name = "xo_board",
> >
> > This ensures the backwards compatibility (when using global lookup),
> > without complicating the node-local naming.
>
> Sure, while thinking more on this, should we finalize the name as xo or
> cxo, I see latter being also used at few places. It would be great to
> get a name and stick to it for longer time :)
> --

I would name it 'cxo' because that's the pin name on this platform.

\
 
 \ /
  Last update: 2019-09-09 13:27    [W:0.053 / U:0.064 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site