lkml.org 
[lkml]   [2019]   [Sep]   [4]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH] eeprom: Deprecate the legacy eeprom driver
On Mon, Sep 02, 2019 at 10:48:38AM +0200, Jean Delvare wrote:
> Time has come to get rid of the old eeprom driver. The at24 driver
> should be used instead. So mark the eeprom driver as deprecated and
> give users some time to migrate. Then we can remove the legacy
> eeprom driver completely.
>
> Signed-off-by: Jean Delvare <jdelvare@suse.de>
> Cc: Arnd Bergmann <arnd@arndb.de>
> ---
> drivers/misc/eeprom/Kconfig | 5 ++++-
> 1 file changed, 4 insertions(+), 1 deletion(-)

You might also want to add a big printk() message when the driver is
loaded that it shouldn't be used.

thanks,

greg k-h

\
 
 \ /
  Last update: 2019-09-04 09:58    [W:0.045 / U:10.524 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site