[lkml]   [2019]   [Sep]   [25]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [RFC PATCH 2/4] iommu/vt-d: Add first level page table interfaces
On Tue, Sep 24, 2019 at 09:38:53AM +0800, Lu Baolu wrote:
> > > intel_mmmap_range(domain, addr, end, phys_addr, prot)
> >
> > Maybe think of a different name..? mmmap seems a bit weird :-)
> Yes. I don't like it either. I've thought about it and haven't
> figured out a satisfied one. Do you have any suggestions?

How about at least split the word using "_"? Like "mm_map", then
apply it to all the "mmm*" prefixes. Otherwise it'll be easily
misread as mmap() which is totally irrelevant to this...


Peter Xu

 \ /
  Last update: 2019-09-25 06:31    [W:0.073 / U:1.604 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site