lkml.org 
[lkml]   [2019]   [Sep]   [15]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [RESEND v4 1/7] mm, slab: Make kmalloc_info[] contain all types of names
On Mon, 16 Sep 2019, Pengfei Li wrote:

> There are three types of kmalloc, KMALLOC_NORMAL, KMALLOC_RECLAIM
> and KMALLOC_DMA.
>
> The name of KMALLOC_NORMAL is contained in kmalloc_info[].name,
> but the names of KMALLOC_RECLAIM and KMALLOC_DMA are dynamically
> generated by kmalloc_cache_name().
>
> This patch predefines the names of all types of kmalloc to save
> the time spent dynamically generating names.
>
> Besides, remove the kmalloc_cache_name() that is no longer used.
>
> Signed-off-by: Pengfei Li <lpf.vector@gmail.com>
> Acked-by: Vlastimil Babka <vbabka@suse.cz>
> Acked-by: Roman Gushchin <guro@fb.com>

Acked-by: David Rientjes <rientjes@google.com>

It's unfortunate the existing names are kmalloc-, dma-kmalloc-, and
kmalloc-rcl- since they aren't following any standard naming convention.

Also not sure I understand the SET_KMALLOC_SIZE naming since this isn't
just setting a size. Maybe better off as INIT_KMALLOC_INFO?

Nothing major though, so:

Acked-by: David Rientjes <rientjes@google.com>

\
 
 \ /
  Last update: 2019-09-15 23:39    [W:0.111 / U:3.736 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site