lkml.org 
[lkml]   [2019]   [Sep]   [13]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH v2 1/2] gpiolib: introduce devm_fwnode_gpiod_get_index()
On Fri, Sep 13, 2019 at 12:40:07PM +0300, Mika Westerberg wrote:
> On Thu, Sep 12, 2019 at 08:22:38PM -0700, Dmitry Torokhov wrote:
> > devm_fwnode_get_index_gpiod_from_child() is too long, besides the fwnode
> > in question does not have to be a child of device node. Let's rename it
> > to devm_fwnode_gpiod_get_index() and keep the old name for compatibility
> > for now.
>
> Shouldn't we convert all the users and drop that monstrosity
> devm_fwnode_get_index_gpiod_from_child() completely?

Yes, once we land this in 5.4 I will start blasting maintainers with
patches.

Thanks.

--
Dmitry

\
 
 \ /
  Last update: 2019-09-13 20:15    [W:0.059 / U:0.368 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site