lkml.org 
[lkml]   [2019]   [Aug]   [30]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
Subject[BUG RT] backtrace on v5.2.9-rt3

I'm triggering the following call splat on 5.2-rt.

[ 63.099414] 006: BUG: sleeping function called from invalid context at kernel/locking/rtmutex.c:968
[ 63.108423] 006: in_atomic(): 0, irqs_disabled(): 1, pid: 173, name: kworker/6:1
[ 63.115779] 006: CPU: 6 PID: 173 Comm: kworker/6:1 Not tainted 5.2.9-test-rt3 #229
[ 63.123329] 006: Hardware name: Hewlett-Packard HP Compaq Pro 6300 SFF/339A, BIOS K01 v03.03 07/14/2016
[ 63.132667] 006: Workqueue: events_long i915_hangcheck_elapsed [i915]
[ 63.139125] 006:
[ 63.141041] 006: Call Trace:
[ 63.143916] 006: dump_stack+0x5c/0x80
[ 63.147654] 006: ___might_sleep.cold.92+0x8d/0x9a
[ 63.152423] 006: rt_spin_lock+0x31/0x40
[ 63.156332] 006: intel_engine_breadcrumbs_irq+0x56/0x320 [i915]
[ 63.162350] 006: intel_engine_signal_breadcrumbs+0x11/0x20 [i915]
[ 63.168540] 006: i915_hangcheck_elapsed+0x199/0x420 [i915]
[ 63.174129] 006: ? __switch_to_asm+0x40/0x70
[ 63.178468] 006: ? __switch_to_asm+0x34/0x70
[ 63.182807] 006: ? __switch_to_asm+0x40/0x70
[ 63.187145] 006: ? __switch_to_asm+0x34/0x70
[ 63.191483] 006: ? __switch_to_asm+0x40/0x70
[ 63.195822] 006: ? __switch_to_asm+0x34/0x70
[ 63.200160] 006: ? __switch_to_asm+0x40/0x70
[ 63.204497] 006: ? __switch_to_asm+0x34/0x70
[ 63.208834] 006: ? __switch_to_asm+0x40/0x70
[ 63.213164] 006: ? __switch_to_asm+0x34/0x70
[ 63.217504] 006: ? __switch_to_asm+0x40/0x70
[ 63.221840] 006: ? __switch_to_asm+0x34/0x70
[ 63.226171] 006: ? __switch_to_asm+0x40/0x70
[ 63.230507] 006: ? __switch_to_asm+0x34/0x70
[ 63.234846] 006: ? __switch_to_asm+0x40/0x70
[ 63.239185] 006: ? __switch_to_asm+0x34/0x70
[ 63.243522] 006: ? __switch_to_asm+0x40/0x70
[ 63.247860] 006: ? __switch_to_asm+0x34/0x70
[ 63.252199] 006: ? __switch_to_asm+0x40/0x70
[ 63.256537] 006: ? __switch_to_asm+0x34/0x70
[ 63.260873] 006: ? __switch_to_asm+0x40/0x70
[ 63.265213] 006: ? __switch_to_asm+0x34/0x70
[ 63.269551] 006: ? __switch_to_asm+0x40/0x70
[ 63.273889] 006: ? __switch_to_asm+0x34/0x70
[ 63.278229] 006: ? __switch_to_asm+0x40/0x70
[ 63.282565] 006: ? __switch_to_asm+0x34/0x70
[ 63.286904] 006: ? __switch_to_asm+0x40/0x70
[ 63.291245] 006: ? __switch_to_asm+0x34/0x70
[ 63.295582] 006: ? __switch_to_asm+0x40/0x70
[ 63.299921] 006: ? _raw_spin_unlock_irq+0xa/0x50
[ 63.304605] 006: ? finish_task_switch+0x104/0x2e0
[ 63.309375] 006: process_one_work+0x1e8/0x4c0
[ 63.313800] 006: worker_thread+0x39/0x3d0
[ 63.317878] 006: ? process_one_work+0x4c0/0x4c0
[ 63.322476] 006: kthread+0x11d/0x140
[ 63.326124] 006: ? kthread_create_on_node+0x60/0x60
[ 63.331066] 006: ret_from_fork+0x35/0x40

Attached is the config and the full dmesg.

Note that I have NO_HZ_FULL enabled and the following on the command
line:

nohz_full=2,3 isolcpus=2,3 rcu_nocbs=2,3


-- Steve

[unhandled content-type:application/octet-stream][unhandled content-type:application/octet-stream]
\
 
 \ /
  Last update: 2019-08-30 18:02    [W:0.067 / U:3.312 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site