lkml.org 
[lkml]   [2019]   [Aug]   [2]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [RFC PATCH] compiler_attributes.h: Add 'fallthrough' pseudo keyword for switch/case use
On Fri 2019-08-02 07:00:42, Neil Horman wrote:
> On Thu, Aug 01, 2019 at 10:26:29PM +0200, Miguel Ojeda wrote:
> > On Thu, Aug 1, 2019 at 10:10 PM <hpa@zytor.com> wrote:
> > >
> > > I'm not disagreeing... I think using a macro makes sense.
> >
> > It is either a macro or waiting for 5+ years (while we keep using the
> > comment style) :-)
> >
> > In case it helps to make one's mind about whether to go for it or not,
> > I summarized the advantages and a few other details in the patch I
> > sent in October:
> >
> > https://github.com/ojeda/linux/commit/668f011a2706ea555987e263f609a5deba9c7fc4
> >
> > It would be nice, however, to discuss whether we want __fallthrough or
> > fallthrough. The former is consistent with the rest of compiler
> > attributes and makes it clear it is not a keyword, the latter is
> > consistent with "break", "goto" and "return", as Joe's patch explains.
> >
> I was having this conversation with Joe, and I agree, I like the idea of
> macroing up the fall through attribute, but naming it __fallthrough seems more
> consistent to me with the other attribute macros. I also feel like its more
> recognizable as a macro. Naming it fallthrough just makes it look like someone
> forgot to put /**/'s around it to me.

I like the "fallthrough". It looks like "return" and it should, no
need to have __'s there..
Pavel
--
(english) http://www.livejournal.com/~pavelmachek
(cesky, pictures) http://atrey.karlin.mff.cuni.cz/~pavel/picture/horses/blog.html
[unhandled content-type:application/pgp-signature]
\
 
 \ /
  Last update: 2019-08-02 14:35    [W:0.120 / U:2.212 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site