[lkml]   [2019]   [Aug]   [2]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [RFC PATCH] compiler_attributes.h: Add 'fallthrough' pseudo keyword for switch/case use
On Fri, Aug 02, 2019 at 02:34:18PM +0200, Pavel Machek wrote:
> I like the "fallthrough". It looks like "return" and it should, no
> need to have __'s there..

Yeah, it would have the same feel as "break", "continue", "return"...

The only place I see this already used is in net/sctp/sm_make_chunk.c,
as a label, which would be trivial to adjust...

Kees Cook

 \ /
  Last update: 2019-08-02 18:10    [W:0.091 / U:1.500 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site