[lkml]   [2019]   [Aug]   [17]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH 06/26] ia64: rename ioremap_nocache to ioremap_uc

On 17.08.2019 10:32, Christoph Hellwig wrote:

> On ia64 ioremap_nocache fails if attributs don't match. Not other

Attributes. :-)

> architectures does this, and we plan to get rid of ioremap_nocache.
> So get rid of the special semantics and define ioremap_nocache in
> terms of ioremap as no portable driver could rely on the behavior
> anyway.
> However x86 implements ioremap_uc with a in a similar way as the ia64

"With a" not really needed?

> version of ioremap_nocache, so implement that instead.
> Signed-off-by: Christoph Hellwig <>

MBR, Sergei

 \ /
  Last update: 2019-08-17 18:02    [W:0.147 / U:8.512 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site