[lkml]   [2019]   [Aug]   [1]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [RFC PATCH] compiler_attributes.h: Add 'fallthrough' pseudo keyword for switch/case use
On Thu, Aug 1, 2019 at 10:10 PM <> wrote:
> I'm not disagreeing... I think using a macro makes sense.

It is either a macro or waiting for 5+ years (while we keep using the
comment style) :-)

In case it helps to make one's mind about whether to go for it or not,
I summarized the advantages and a few other details in the patch I
sent in October:

It would be nice, however, to discuss whether we want __fallthrough or
fallthrough. The former is consistent with the rest of compiler
attributes and makes it clear it is not a keyword, the latter is
consistent with "break", "goto" and "return", as Joe's patch explains.


 \ /
  Last update: 2019-08-01 22:27    [W:1.418 / U:0.864 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site