lkml.org 
[lkml]   [2019]   [Jun]   [11]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH] mm: treewide: Clarify pgtable_page_{ctor,dtor}() naming
On Mon, Jun 10, 2019 at 01:05:11PM -0700, Andrew Morton wrote:
> On Mon, 10 Jun 2019 17:33:54 +0100 Mark Rutland <mark.rutland@arm.com> wrote:
>
> > The naming of pgtable_page_{ctor,dtor}() seems to have confused a few
> > people, and until recently arm64 used these erroneously/pointlessly for
> > other levels of pagetable.
> >
> > To make it incredibly clear that these only apply to the PTE level, and
> > to align with the naming of pgtable_pmd_page_{ctor,dtor}(), let's rename
> > them to pgtable_pte_page_{ctor,dtor}().
> >
> > The bulk of this conversion was performed by the below Coccinelle
> > semantic patch, with manual whitespace fixups applied within macros, and
> > Documentation updated by hand.
>
> eep. I get a spectacular number of rejects thanks to Mike's series
>
> asm-generic-x86-introduce-generic-pte_allocfree_one.patch
> alpha-switch-to-generic-version-of-pte-allocation.patch
> arm-switch-to-generic-version-of-pte-allocation.patch
> arm64-switch-to-generic-version-of-pte-allocation.patch
> csky-switch-to-generic-version-of-pte-allocation.patch
> m68k-sun3-switch-to-generic-version-of-pte-allocation.patch
> mips-switch-to-generic-version-of-pte-allocation.patch
> nds32-switch-to-generic-version-of-pte-allocation.patch
> nios2-switch-to-generic-version-of-pte-allocation.patch
> parisc-switch-to-generic-version-of-pte-allocation.patch
> riscv-switch-to-generic-version-of-pte-allocation.patch
> um-switch-to-generic-version-of-pte-allocation.patch
> unicore32-switch-to-generic-version-of-pte-allocation.patch
>
> But at least they will make your patch smaller!

Aha; thanks for the heads-up!

Given this cleanup isn't urgent, I'll sit on it until the above has
settled.

Mark.

\
 
 \ /
  Last update: 2019-06-11 11:39    [W:0.058 / U:10.272 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site